Маршрутизация в сетях

Статическая маршрутизация на роутерах Cisco

В прошлой шпаргалке мы выполнили базовую настройку роутера и назначили IP-адреса интерфейсам роутера («Базовая настройка роутера Cisco»).

Однако (надеюсь Вы помните из готового примера), у нас еще нет возможности отправить удачный пинг в другую сеть (из PC1 к PC3).

Для этого мы и настроим статическую маршрутизацию, которая будет объяснять роутеру где находится другая сеть.

// Так я буду обозначать комментарии.

    Устанавливаем консольное соединение через гипертерминал со следующими настройками:

  • Скорость: 9600; Биты данных: 8; Четность: Нет; Стоповые биты: 1; Управление потоком: Нет;
  • //при входе на роутер вводим пароль — cisco
  • R1>enable//Входим в привилегированный режим.
  • //вводим пароль — class
  • R1#
  • R1#configure terminal//заходим в режим глобальной конфигурации
  • R1(config)#ip route 172.16.0.0 255.255.255.128 Serial0/0/0//это команда для ввода статического маршрута/ Объясняю вкратце: ip route — это команда, говорящая роутеру, что сейчас будет введен статический маршрут; 172.16.0.0 — это удаленная и неизвестная роутеру сеть; 255.255.255.128 — это маска удаленной сети; serial0/0/0 — это на какой интерфейс слать пакеты, предназначающиеся для той, удаленной сети.
  • //помимо вышеназванного способа можно воспользоваться другими командами:
    ip route 172.16.0.0 255.255.255.128 192.168.0.194 — в этом случае все тоже самое, только вместо указания интерфейса на какой слать пакеты, указан IP-адрес подключенного интерфейса следующего роутера.
    ip route 172.16.0.0 255.255.0.0 Serial0/0/0 — здесь мы увеличили диапазон адресов маской. Теперь на интерфейс уйдут не только пакеты с адресами 172.16.0.1-126, но и 172.16.255.254. Это называется суммированием маршрутов, и заслуживает другой статьи.
    ip route 0.0.0.0 0.0.0.0 Serial0/0/0 — а это называется маршрут по умолчанию, т.е. всё, что не предназначается для известных роутеру сетей уйдёт на интерфейс Serial0/0/0.
  • R1(config-line)#end//выходим в привилегированный режим EXEC Mode
  • R1#show running-config//Проверяем введенные данные.
  • R1#copy running-config startup-config//Сохраняем произведенную настройку в энерго-независимую память.

Скачать выполненное задание настройки роутера

Предлагаю скачать файл с выполненным заданием для программы эмулятора PacketTracer, открыть его и посмотреть на реализацию. Роутер R2 тоже настроен со статической маршрутизацией, следовательно теперь всё удачно пингуется.

Базовая настройка роутеров Cisco со статичной маршрутизацией в Packet Tracer

Настройка роутера копированием конфигурации

    Для автоматической базовой настройки (всё, что выше) маршрутизатора выполните следующие действия:

  • 1. Скопируйте текст ниже в буфер обмена: веделите всё, кликните правой кнопкой по выделенному и выберите «Копировать».
  • 2. При необходимости очистите роутер от всех настроек и перезагрузите его.
  • 3. Войдите в режим глобальной конфигурации и вызовите меню Гипер Терминала «Правка», а в нём «Передать главному компьютеру».
  • 4. Обязательно проверьте настройки с помощью команды
  • 5. При необходимости включите интерфейсы командой no shutdown из режима каждого интерфейса

Вы также можете скачать текстовый файл с настройками (R1) выше: basic_configure_router_R1_with_static_routing.txt.

Скачайте заодно (для сравнения) файл с настроуками для роутера R2: basic_configure_router_R2_with_static_routing.txt.

Маршрутизатор имеет несколько портов, каждый из которых включается в другую подсеть и по логике доступа к среде каждой подсети является ее независимым узлом. Поэтому каждый порт маршрутизатора имеет свой MAC –адрес и свой сетевой адрес, а само устройство в целом адреса не имеет.

Задачу выбора маршрута из нескольких возможных решают маршрутизаторы и конечные узлы. Маршрут выбирается на основании имеющейся у устройств информации о топологии сети, а также на основании указанного критерия (метрики) выбора маршрута. Обычно в качестве критерия выступает время прохождения маршрута отдельным пакетом или средняя пропускная способность маршрута для серии пакетов. Часто также используется весьма простая метрика, учитывающая только количество пройденных в маршруте промежуточных маршрутизаторов.

Информация о наилучших маршрутах хранится в таблице маршрутизации. Таблицы разных маршрутизаторов могут выглядеть по-разному, но в них обязательно будут присутствовать следующие поля:

Сеть назначения Сетевой адрес следующего маршрутизатора Идентификатор собственного выходного порта Метрика. (например, расстояние до сети назначения в количестве промежуточных узлов)

Для уменьшения размеров таблиц маршрутизации в больших сетях вводят путь по умолчанию. При этом в таблицу данного маршрутизатора включаются непосредственно подключенные к нему сети, сети, расположенные поблизости, и тупиковые ветви сети, а остальные части сети адресуются маршрутом по умолчанию.

Рис. 7.2. Построение таблиц маршрутизации

Некоторые реализации сетевых протоколов допускают наличие в таблицах нескольких строк, соответствующих одному адресу сети назначения, если их метрики одинаковы или разница между ними не превышает заданного значения. В многомаршрутных таблицах должно быть задано правило, по которому выбирается один из доступных альтернативных маршрутов. Чаще всего один путь является основным, а остальные – резервными. Резервные маршруты могут выбираться тогда, когда основной путь по причине технических неполадок становится недоступен.

Наличие нескольких маршрутов к одному узлу делают возможной передачу трафика к этому узлу по нескольким каналам параллельно (поочередная посылка пакетов по каждому маршруту), что повышает пропускную способность и надежность сети. Такая возможность называется балансировкой нагрузки и поддерживается рядом протоколов маршрутизации.

Если маршрутизатор поддерживает несколько классов сервиса для пакетов (по разным критериям), то для каждого класса (критерия) составляется отдельная таблица маршрутизации.

Как уже отмечалось, задачу маршрутизации решают не только маршрутизаторы, но и конечные узлы-компьютеры.

Протокол сетевого уровня конечного узла прежде всего определяет, находятся ли отправитель и получатель в одной сети (тогда маршрутизация не нужна) или пакет адресован компьютеру другой сети (тогда нужна маршрутизация). Таблица маршрутизации у компьютера выглядит аналогично таблице маршрутизатора, только гораздо меньше по размерам. Конечный узел вообще может обходиться без нее, так как ему достаточно знать только адрес маршрутизатора по умолчанию (из ЛВС во внешнюю сеть обычно ведет только один маршрутизатор).

Маршрутизаторы строят свои таблицы в основном автоматически, обмениваясь друг с другом служебной информацией с помощью сообщений протоколов маршрутизации. Для конечных узлов таблицы маршрутизации либо создаются вручную администраторами сети, либо автоматически и хранятся в виде файлов на дисках.

Например, для стека TCP/IP создавать и редактировать записи таблиц можно с помощью утилиты Route, а для автоматической настройки стека, откуда потом берется информация для таблицы маршрутизации компьютера, существует протокол DHCP. Протокол прикладного уровня DHCP имеет клиент серверную организацию. Сервер DHCP может назначать клиентским компьютерам постоянные или динамические IP-адреса из общего адресного пула, или (для некоторых компьютеров) те адреса, которые указал администратор сети. В отличие от постоянного динамический адрес назначается компьютеру при его запуске на определенный промежуток времени, а по истечении этого времени, если компьютер не активен, адрес снова возвращается в пул.

Таблица маршрутизации узла A на рис.7.2. может выглядеть примерно следующим образом:

Сети назначения Сетевой адрес следующего маршрутизатора Идентификатор собственного выходного порта Расстояние до сети назначения (число промежуточных узлов)
S12 MA
Default M17(1) MA

7.3. Реализация межсетевого взаимодействия средствами стека TCP/IP

7.3.1.Краткая характеристика стека TCP/IP

В стеке TCP/IP определены четыре уровня. Каждый из этих уровней ориентирован на решение ряда задач по организации надежной и производительной работы составной сети, части которой построены на основе разных сетевых технологий. Так как стек TCP/IP был разработан до появления модели взаимодействия открытых систем OSI, то, соответствие уровней стека TCP/IP уровням модели OSI не совсем точно (рис.7.3).

Уровень OSI Названия протоколов Уровень ТСP/IP
Прикладной Telnet, FTP, SMTP, HTTP, SNMP,… Прикладной
Представительный SSL
Сеансовый TCP, UDP Основной уровень
Транспортный
Сетевой IP, RIP,OSPF,ARP,ICMP Уровень Межсетевого взаимодействия
Канальный Ethernet, TokenRing, FDDI, SLIP, PPP, HDLC, Frame relay, ATM Уровень сетевых интерфейсов (конкретные протоколы стеком не регламентируется)
Физический Спецификации для разных типов кабеля (например, 100Base TX)

Рис. 7. 3. Соответствие уровней стека TCP/IP семиуровневой модели OSI

Уровень межсетевого взаимодействия

Стержнем всей архитектуры является уровень межсетевого взаимодействия, который реализует концепцию передачи пакетов в режиме без установления соединений, то есть дейтаграммным способом. Именно этот уровень обеспечивает возможность перемещения пакетов по сети, используя тот маршрут, который в данный момент является наиболее рациональным. Этот уровень также называют уровнем internet, указывая тем самым на основную его функцию — передачу данных через составную сеть.

Основным протоколом сетевого уровня (в терминах модели OSI) в стеке является протокол IP (Internet Protocol).

Этот протокол изначально проектировался как протокол передачи пакетов в составных сетях, состоящих из большого количества локальных сетей, объединенных как локальными, так и глобальными связями. Поэтому протокол IP хорошо работает в сетях со сложной топологией, рационально используя наличие в них подсистем и экономно расходуя пропускную способность низкоскоростных линий связи. Так как протокол IP является дейтаграммным протоколом, он не гарантирует доставку пакетов до узла назначения и не занимается повторной отправкой испорченных и потерянных пакетов, при необходимости это делает протокол транспортного уровня TCP.

Важное свойство IP протокола – способность фрагментировать пакет с длинным полем данных при передаче через сеть, допускающую только кадры с меньшим полем данных.

К уровню межсетевого взаимодействия относятся также все протоколы, связанные с составлением и модификацией таблиц маршрутизации, такие как протоколы сбора маршрутной информации RIP (Routing Internet Protocol) и OSPF (Open Shortest Path First), протокол разрешения сетевых адресов в локальные ARP, протокол группового управления IGMP, а также протокол межсетевых управляющих сообщений ICMP (Internet Control Message Protocol).

Последний протокол предназначен для обмена информацией об ошибках между маршрутизаторами сети и узлом-источником пакета. С помощью специальных пакетов ICMP сообщает о невозможности доставки пакета, о превышении времени жизни или продолжительности сборки пакета из фрагментов, об аномальных величинах параметров, об изменении маршрута пересылки и типа обслуживания, о состоянии системы и т.

п.

Основной уровень

Поскольку на сетевом уровне не устанавливаются соединения, то нет никаких гарантий, что все пакеты будут доставлены в место назначения целыми и невредимыми или придут в том же порядке, в котором они были отправлены. Эту задачу — обеспечение надежной информационной связи между двумя конечными узлами — решает основной уровень стека TCP/IP, называемый также транспортным.

На этом уровне функционируют протокол управления передачей TCP (Transmission Control Protocol) и протокол дейтаграмм пользователя UDP (User Datagram Protocol). Протокол TCP обеспечивает надежную передачу сообщений между удаленными прикладными процессами за счет образования логических соединений, т.е. это протокол с установлением соединения между получателем и отправителем. Этот протокол позволяет равноранговым объектам на компьютере-отправителе и компьютере-получателе поддерживать обмен данными в дуплексном режиме. TCP позволяет без ошибок доставить сформированный на одном из компьютеров поток байт в любой другой компьютер, входящий в составную сеть. TCP делит поток байт на части — сегменты, нумерует их и передает ниже лежащему уровню межсетевого взаимодействия. Пересылка пакетов в протоколе TCP осуществляется методов скользящего окна: с подтверждением получения пакетов с помощью квитанций от получателя и повторной отсылкой испорченных пакетов отправителем в том случае, если он (отправитель) не получил квитанцию в течении времени таймаута. После того как все сегменты в пакетах будут доставлены средствами протокола межсетевого взаимодействия IP в пункт назначения, протокол TCP снова соберет их в непрерывный поток байт.

Протокол UDP обеспечивает передачу прикладных пакетов дейтаграммным способом, как и главный протокол уровня межсетевого взаимодействия IP, и выполняет только функции связующего звена (мультиплексора) между сетевым протоколом и многочисленными службами прикладного уровня или пользовательскими процессами. Этот протокол работает быстрее, но не гарантирует доставки пакетов, поэтому может использоваться, для передачи единичных сообщений или мультимедийного трафика реального времени.

Прикладной уровень

Прикладной уровень объединяет все службы, предоставляемые системой пользовательским приложениям. За долгие годы использования в сетях различных стран и организаций стек TCP/IP накопил большое количество протоколов и служб прикладного уровня. Прикладной уровень реализуется программными системами, построенными в архитектуре клиент-сервер, базирующимися на протоколах нижних уровней. В отличие от протоколов остальных трех уровней, протоколы прикладного уровня занимаются деталями конкретного приложения и «не интересуются» способами передачи данных по сети. Этот уровень постоянно расширяется за счет присоединения к старым, прошедшим многолетнюю эксплуатацию сетевым службам типа Telnet, FTP, TFTP, DNS, SNMP сравнительно новых служб таких, например, как протокол передачи гипертекстовой информации HTTP, IMAP4, NTP и др.

Краткая справка:

HTTP (Hypertext Transfer Protocol) – используется клиентами и серверами WEB для обмена запросами на передачу файлов и самими файлами. Броузер клиента устанаволивает TCP -соединение с сервером и отправляет запрос на передачу определенного файла. В ответ сервер посылает файл, который отображается броузером в виде WEB –страницы.

HTTP – сообщения также содержат разнообразные поля с информацией о системах, между которыми установлено соединение.

HTTPS или S-HTTP (Secure Hypertext Transfer Protocol) – используется в транзакциях между клиентами и серверами WEB для авторизации пользователей и шифрования передаваемых данных. Протокол HTTPS работает поверх протокола SSL.

FTP (File Transfer Protocol) – применяется для передачи файлов между TCP/IP – системами. Клиент FTP просматривает структуру каталога на сервере, к которому подключен, и выбирает фай2лы для пересылки. В работе протокола применяются 2 отдельных порта. Подключаясь к серверу, клиент FTP использует для установки управляющего соединения TCP – порт 21. Это соединение остается пока клиент его не прервет. При попытке загрузки файла программа открывает второе TCP –соединение с портом 20 для передачи данных, которое закрывается после завершения передачи файла.

Особенность FTP еще и в том, что в большинстве TCP/IP –систем он представляет собой не просто протокол, которое используют другие приложения, а является самостоятельным приложением.

TFTP (Trivial File Transfer Protocol) – сокращенная версия FTP. Вместо TCP в нем используется UDP. Этот протокол не в отличии от полного не поддержмвает автори0зацию и интерфейсные функции. Первоначально он разрабатывался для бездисковых станций, которым необходимо копировать исполняемые загрузочные файлы с сетевого сервера.

SMTP (Simple Mail Transfer Protocol) – применяется почтовыми серверами для обмена сообщениями по сети.

POP3 (Post Office Protocol) – один из протоколов, применяемых клиентами электронной почты для доставки сообщений с почтового сервера.

IMAP4 (Internet Mail Access Protocol) – почтовый протокол, с помощью которого клиенты получают сообщения на сервере. Протокол обладает большими возможностями, чем POP3. Он, например, позволяет пользователю создавать отдельные папки для хранения сообщений на сервере.

NTP (Network Time Protocol) – служит для синхронизации часов компьютеров в сети.

DNS (Domain Name System) – используется в TCP/IP системах для преобразования доменных имен хостов в IР – адреса.

DHCP (Dynamic Host Configuration Protocol) – применяется в сети для получения рабочими станциями от сервера информации о параметрах конфигурации стека TCP/IP.

SNMP (Simple Network Management Protocol) – протокол управления сетью, который используется сетевыми администраторами для сбора информации о различных узлах сети. С помощью сообщений SNMP встроенные в узлы программы – агенты собирают статистические сведения и передают их дистанционно на центральную консоль управления сетью.

Telnet – программа для эмуляции командной строки терминала, позволяющая пользователю подключиться к удаленному компьютеру и запускать на нем команды и программы.

Уровень сетевых интерфейсов

Идеологическим отличием архитектуры стека TCP/IP от многоуровневой организации других стеков является интерпретация функций самого нижнего уровня — уровня сетевых интерфейсов. Протоколы этого уровня должны обеспечивать интеграцию в составную сеть сетей разных технологий. Отсюда следует, что этот уровень нельзя определить раз и навсегда. Уровень сетевых интерфейсов в протоколах TCP/IP не регламентируется, но он поддерживает все популярные стандарты физического и канального уровней: для локальных сетей это Ethernet, Token Ring, FDDI, Fast Ethernet, Gigabit Ethernet, для глобальных сетей — протоколы соединений «точка-точка» SLIP и РРР, протоколы территориальных сетей с коммутацией пакетов Х. 25, frame relay, ATM. Обычно при появлении новой технологии локальных или глобальных сетей она быстро включается в стек TCP/IP.


⇐ Предыдущая67686970717273747576Следующая ⇒


Дата публикования: 2014-11-26; Прочитано: 2270 | Нарушение авторского права страницы



studopedia.org — Студопедия.Орг — 2014-2018 год.(0.003 с)…

Есть две сети 192.168.10.0/24 и 192.168.11.0/24. Можно ли настроить доступ между сетямяти используя RouterOS ?

radioamator

5.12.2008, 20:26

Здравствуйте. Имеется нелегальная студенческая сеть,
сделанная на неуправляемом оборудовании и без роутеров.

Исходный код

————— —————-
| | ——— | |
| Общага 1 |———-| Свич |———| Жилые дома |
| (200 Компов) | |_______| | (70 Компов) |
|______________| | |______________|
|
|
—————-
| |
| Общага 2 |
| (100 Компов) |
|______________|

Во всей сети ip лежат в диапазоне 10.0.100.XXX, 10.0.101.XXX,
и 10.0.111.XXX. Хотим поставить между общагой 1 и свичём роутер
на базе MikrоTik, то есть поделить сеть для начала на 2 сегмента.
Можно ли настроить MikroTik так, чтобы у каждого пользователя
сети остался свой ip. Заранее спасибо.

rem_lex

10.12.2008, 19:42

все просто, ставишь микротик, 3 сетевые, потом:

Код

/ ip address
add address=192.168.100.1/24 network=192.168.100.0 broadcast=192.168.100.255 \
    interface=ether1 comment="local 100" disabled=no
add address=182.168.101.1/24 network=192.168.101.0 broadcast=192.168.101.255 \
    interface=ether2 comment="local 101" disabled=no
add address=182.168.111.1/24 network=192.168.111.0 broadcast=192.168.111.255 \
    interface=ether3 comment="local 111" disabled=no

дефолтовы правила мкротика разрешают полную маршрутизацию между интерфейсами, после этого у каждого из клиентов нужно будет прописать шлюз соответвующие его подсети и все заработает

radioamator

12.12.2008, 12:43

Я роутер хочу поставить как бы в обрыв сети, то есть сделать чтобы кабель от обшаги_1 шёл в роутер, а от рорутера на свич, изображённый на рисунке (по крайней мере сейчас).

Тут проблема в другом. Ip адреса у нас распределены случайно, то есть кому какой понравился тот такой и берёт, поэтому и в общаге_1 и общаге_2 и а жилых жомах есть машины с ip 100. Можно ли как-то настоить маршрутизацию, чтобы все остались при своём ip?

rem_lex

19.12.2008, 12:17

для начала прекратить буспредел с адресами, только потом что-то делать, судя по скорости реакции вам это не припадочно надо…
а конфиг который я дал, как раз и подходит для вставки роутера в разрыв

Доброго времени суток.
Есть две сети, между ними стоит Mikrotik. Форвардит всё замечательно, в том числе и arp. Но вот как раз arp между сетями надо запретить. Правильно ли я понимаю — надо делать бридж и в файерволе для него делать правило "… -p arp … action=drop"?

Про nat забыли

Добрый день, есть mikrotik 1100ahx2, на нем крутиться балансировка между провайдерами, много различных сетей, все сидит на нем. Не как не получается запретить маршрутизацию между сетями, т.е к примеру запретить видеть из сети 192.168.1.0/24 сеть 175.16.22.0/24, направьте на путь истинный. Спасибо

pacific

22.10.2012, 19:25

Все. Разобрался. Забыл в одной сети указать в качестве шлюза микротик. Указал и все зароботало. NAT непонадобилась.

verysimply

13.3.2013, 10:37

Всем привет!
я чет совсем разобраться не могу как настроить маршрутизацию между сетями?
Дано:
RB951n
Ether2 адрес интерфейса и собственно шлюз 192.168.1.1/24 подсеть 1
Ether3 адрес интерфейса и собственно шлюз 192.168.2.1/24 подсеть 2
в подсети 1 есть PC1 c адресом 192.168.1.100
в подсети 2 есть PC2 c адрсеом 192.168.2.254
с PC2 пингуются интерфейсы подсети 1 и 2, но не пингуется PC1.
c RB951n пингуется все.
правил еще нет никаких.

(хотя ставил forward access из подсети 1 в 2 и обратно)
nat пока не настраивал.
интерфейсы в Bridge пока не ставил, (хотя пробовал ставить все равно таже ситуация)

Растолкуйте ребята пожалуйста что нужно прописать, чтобы хотя бы пинговался PC1, а в лучшем случае я видел PC1 в сетевом окружении с PC2.
Или укажите где почитать про принципы маршрутизации в mikrotik.

evpadallas

19.8.2016, 16:10

Помогите разобраться.

С одной стороны стоит OpenVPN сервер на Ubuntu (сеть1), с другой Mikrotik на котором настроен клиент, а за ним сеть2. Получилось настроить чтобы клиент подключался к сети1, но не получается настроить видимость из сети1 сеть2. точнее я пингую VPN интерфейс на микротике, но 88-ю подсеть не вижу. Предполагаю что где-то роутинги не дописаны или firewall блокирует. помогите настроить.

evpadallas

20.8.2016, 21:18

Прочитал, EoIP не подходит, на одной стороне стоит OpenVPN на Ubuntu. Канал нужен шифрованный. У меня получилось поднять канал связи, но он какой-то избирательный получился. Три компьютера пингуются, остальные — нет, например, 192.168.10.3 пинг отличный, 192.168.10.2 — нет.

Компьютеры одинаковые и с роутера где стоит OpenVPN пингуются. Из сети за OpenVPN 88-я подсеть микротика не пингуется. Как посмотреть подробные логи, чтобы понять что блокирует траффик?

evpadallas

22.8.2016, 19:22

Добился продвижений.
Все компьютеры пингуются за OpenVPN сервером, с компьютера за маршрутизатором. С любого компьютера за OpenVPN пингуется внутренний IP на микротике полученный интерфейсом клиента OVPN. Теперь вопрос, как на микротике, прописать проброс трафика с интерфейса OVPN на интерфейс ether2?
Спасибо!

В нате надо прописать правило.

В роутах маршрут.

Цитата(NeOPS @ 14.7.2007, 17:13)

Есть две сети 192.168.10.0/24 и 192.168.11.0/24. Можно ли настроить доступ между сетямяти используя RouterOS ?

Конечно можно! Думаю это будет самый дешевый вариант.

Цитата(Shuher @ 31.7.2007, 11:13)

Конечно можно! Думаю это будет самый дешевый вариант.

А если не трудно, краткое описание настроек можно? Спасибо.

Код

/ ip address
add address=192.168.10.1/24 network=192.168.10.0 broadcast=192.168.10.255 \
    interface=ether1 comment="local 10" disabled=no
add address=182.168.11.1/24 network=192.168.11.0 broadcast=192.168.11.255 \
    interface=ether2 comment="local 11" disabled=no

дальше на своих клиента указываешь шлюзы 192,168,10,1 и 192,168,11,1 в соответствии их подсетям или вручную указываешь маршруты
для винды 10 подсети:

Код

route add 192.168.11.0 mask 255.255.255.0 192.168.11.1 -p

и для 11 подсети

Код

route add 192.168.10.0 mask 255.255.255.0 192.168.10.1 -p

соотвественно
и все должно работать

Цитата(andyboy @ 16.2.2009, 9:26)

Доброго времени суток.
Есть две сети, между ними стоит Mikrotik. Форвардит всё замечательно, в том числе и arp. Но вот как раз arp между сетями надо запретить. Правильно ли я понимаю — надо делать бридж и в файерволе для него делать правило "… -p arp … action=drop"?

на бридже нужно установить proxy-arp

Цитата(rem_lex @ 10.12.2008, 19:42)
все просто, ставишь микротик, 3 сетевые, потом:

Код

/ ip address
add address=192.168.100.1/24 network=192.168.100.0 broadcast=192.168.100.255 \
    interface=ether1 comment="local 100" disabled=no
add address=182.168.101.1/24 network=192.168.101.0 broadcast=192.168.101.255 \
    interface=ether2 comment="local 101" disabled=no
add address=182.168.111.1/24 network=192.168.111.0 broadcast=192.168.111.255 \
    interface=ether3 comment="local 111" disabled=no

дефолтовы правила мкротика разрешают полную маршрутизацию между интерфейсами, после этого у каждого из клиентов нужно будет прописать шлюз соответвующие его подсети и все заработает

Настроил таким образом. С Микротика пингуются все сети, а из сетей пингуются только интерфейсы микротика (все). Я что-то пропустил?

Цитата(Vasia @ 13.1.2012, 7:11)

Про nat забыли

Вы имеете ввиду:
Пример отображения 1:1 одной сети в другую?
Если вы хотите объединить сеть 11.11.11.0/24 с сетью 2.2.2.0/24, то вам необходимо
использовать трансляцию адреса источника и адреса назначения в паре с действием
action=netmap

Цитата

/ip firewall nat add chain=dstnat dst -address=11.11.11.1-11.11.11.254
action=netmap to-addresses=2.2.2.1-2.2.2.254
/ip firewall nat add chain=srcnat src-address=2.2.2.1-2.2.2.254 action=netmap
to-addresses=11.11.11.1-11.11.11.254

NAT настройте, например так:
/ip firewall nat> print
Flags: X — disabled, I — invalid, D — dynamic
3 chain=srcnat action=masquerade src-address=192.168.0.0/16

На микротике добавьте маршрут к сети за ubuntu со шлюзом адрес openvpn туннеля.На openvpn прописывайте маршрут в 88 сеть, а на микротике проверьте или добавьте правило в Nat. Какое без понятия. Я о структуре вашей сети ничего не знаю.

Это текстовая версия — только основной контент. Для просмотра полной версии этой страницы, пожалуйста, нажмите сюда.

Маршрутизация

Теперь, когда мы знаем как осуществляется адресация, группируются адреса, мы можем изучить процесс маршрутизации.

Маршрутизация (routing) — процесс передачи пакетов.

Правила маршрутизации конечных устройств (хостов)

Конечные устройства, при передаче пакетов, полагаются на следующую логику:

  1. Если IP адрес получателя находится в той же самой подсети (т.е. относится к тому же номеру сети и принадлежит тому же диапазону) что и IP адрес отправителя, то устройство отправляет пакет напрямую получателю.
  2. Если IP адрес получателя находится в другой подсети (т.е. относится к другому номеру сети, а значит принадлежит другому диапазону), то устройство отправляет пакет на шлюз по умолчанию (default gateway). Чаще всего это интерфейс маршрутизатора (router).

Очень важная информация!

Как видно из «гифки» (Рисунок 4.5), пакет, предназначенный для ПК2, отправляется напрямую (в этом случае коммутатор не рассматривается, это устройство второго уровня модели OSI и никакое отношение к пакетам не имеет), потому что находится в одной сети с ПК1 (1.0.0.0/8), следовательно красный пакет ПК1 отправит по первому правилу.

А пакет, предназначенный для ПК4, ПК1 отправит по второму правилу, т.к. ПК4 находится в другой подсети.

Маршрутизация Router (маршрутизатор)

Освежим некоторые моменты

Маршрутизатор (Router) — сетевое устройство, соединяющее части сети для передачи IP-пакетов. Основная функция роутеров — маршрутизация.

Правила группировки адресов:

  • Все IP адреса в одной группе не должны быть разделены маршрутизатором (router).
  • Все IP адреса разделенные маршрутизатором должны быть в разных группах.

Из правил группировки адресов мы можем заключить, что на каждом интерфейсе у маршрутизатора должны быть разные IP адреса, принадлежащее разным номерам сетей (и разные MAC адреса!!).

Прежде чем разобрать большой пример, укажем несколько важных моментов:

  • на протяжении всего пути IP пакет не меняется (очень важно!);
  • при переходе пакета из одной подсети в другую, меняется фрейм, он является транспортом для переноса пакета внутри одного сегмента сети (очень важно!);
  • номера сетей, подключенные к маршрутизатору напрямую, по умолчанию появляются в таблице маршрутизации (очень важно!);
  • так же маршруты бывают либо статические,человек сам прописывает их, либо динамические, появившиеся при помощи протоколов маршрутизации (очень важно!).

Следует пояснить некоторые элементы рисунка 4.6. Я старался максимально поиграть с адресацией и выбрал не стандартные номера сетей. Рядом с маршрутизаторами прописан последний октет IP адреса и номер интерфейса, например, 1.20.20.46 — адрес интерфейса fa0/1, на маршрутизаторе R1. Так же на рисунке не показаны MAC адреса, будем вместо них писать имена устройств, а в случае с роутерами, еще и портов. Теперь пошагово разберем путь пакета от компьютера Андрея к веб-серверу.

Шаг 1.

Компьютер Андрея (PC1) формирует пакет с адресом отправителя 10.20.20.110 и адресом получателя 200.20.20.70 (Рисунок 4.7). На протяжении всего пути этот пакет меняться не будет.

На этом же шаге ПК Андрея принимает решение куда пакет смаршрутизировать (передать). Согласно логике описанной выше, пакет будет смаршрутизирован на шлюз по умолчанию (ip адрес получателя принадлежит другому номеру сети). В данном примере шлюзом по умолчанию для ПК Андрея является ip адрес интерфейса fa0/0 (10.20.20.1) принадлежащий R1. Чтобы передать пакет на R1, ПК Андрея будет создавать фрейм указывая свой MAC адрес в качестве отправителя и MAC адрес R1 в качестве получателя. Как и было сказано выше канальный уровень является транспортом для передачи пакета внутри одной подсети (сегмента сети). Вместо MAC адресов используем названия конечных устройств, как было оговорено выше (Рисунок 4.8).

Шаг 2.

R1 принимает фрейм, обрабатывает его, т.к. видит свой MAC адрес. Первым делом происходит проверка целостности фрейма (проверяется контрольная сумма — FCS), это часть процесса деинкапсуляции (так же убирается заголовок канального уровня), после которого остается пакет. Из всего пакета маршрутизатору нужен только IP адрес получателя, по нему он ищет маршрут в свое таблице маршрутизации. Рассмотрим таблицу маршрутизации R1.

Таблица 4.4 Таблица маршрутизации R1

Первые два маршрута это номера сетей подключенные напрямую к R1, одна подключена к Fa0/0 (10.20.20.0/24), другая к Fa0/1 (1.20.20.44/30). Эти маршруты появляются сами, как только мы назначили адреса на интерфейсы. Остальные два маршрута добавлены статически, т.е. кто-то их туда внес. Третий и четвертый маршруты проходят через R2, именно поэтому мы указываем Fa0/1, как исходящий интерфейс (откуда будет вылетать пакет), и в третьей колонке указываем IP адрес Fa 0/3 на R2. R1 определит, что адрес 200.20.20.70 принадлежит номеру сети 200.20.20.64/27 (четвертая строчка в таблице маршрутизации R1), следовательно надо отправить этот пакет через Fa0/1 на IP адрес 1.20.20.45 ( этот адрес он использует для нахождения MAC адреса следующего маршрутизатора). И так, после того как маршрутизатор определился с маршрутом, он инкапсулирует пакет в новый фрейм (добавляет к пакету новый заголовок и новую контрольную сумму).

Шаг 3.

R2 принимает фрейм, обрабатывает его, т.к. видит свой MAC адрес. Далее аналогично шагу 2 происходит деинкапсуляция, после которой остается пакет. R2 ищет маршрут соответствующий адресу получателя пакета, рассмотрим его таблицу маршрутизации.

Таблица 4.6 Таблица маршрутизации R3

Опять же первые два маршрута это номера сетей подключенные напрямую. Третий маршрут проходит через R1, соответственно указывается интерфейс маршрутизатора R2, который смотрит в сторону R1 (Fa0/3) и указывается адрес R1. Четвертый маршрут, именно этот подходит для продвижения нашего пакета дальше, указывает что адрес 200.20.20.70 принадлежит номеру сети 200.20.20.64/27, следовательно надо отправить этот пакет через Fa0/1 используя IP адрес 130.21.21.25 (IP адрес интерфейса fa 0/2 на R3). После того как маршрутизатор определился с маршрутом, он инкапсулирует пакет в новый фрейм (добавляет к пакету новый заголовок и новую контрольную сумму).

Шаг 4.

R3 принимает фрейм и обрабатывает его. Далее аналогично шагам 2 и 3 происходит деинкапсуляция, после которой остается пакет. R3 ищет маршрут соответствующий адресу получателя пакета, рассмотрим его таблицу маршрутизации.

Таблица 4.5 Таблица маршрутизации R2

R3 обнаружит, что пакет попадает по маршрут подсоединенный напрямую, т.е. ему останется найти MAC адрес соответствующий IP адресу получателя и отправить фрейм (это соответствие скрывается за технологией работы протокола ARP, об этом далее).

Очень важно понимать и представлять взаимодействие канального и сетевого уровней, поэтому ниже добавлено две «гифки», первая от ПК1 к ПК2, вторая от ПК2 к ПК1. Обратите внимание на то как меняется фрейм, а пакет остается неизменным.

Итоги примера

Подведя итог можно сказать, что маршрутизация работает при помощи двух главных правил:

  1. Процесс маршрутизации передает пакеты (L3 пакеты или единицы данных сетевого уровня), основываясь на адресе получателя этого пакета.
  2. Процесс маршрутизации использует канальный уровень, чтобы инкапсулировать пакеты в фреймы и передать их по физической среде.

Из этих правил и применения их на примере можно сделать заключение — пакет не меняется при движении от отправителя к получателю, но фрейм, который перевозит этот пакет, постоянно изменяется при переходе из одного сегмента сети в другой.

Если вы нашли в тексте ошибку, выделите текст и нажмите Ctrl + Enter.

Copyright © gurkin33 2016 , Cisco Packet Tracer лабораторные. Подготовка к CCNA, ICND1, ICND2. feedback@gurkin33.ru
Номер сети/префикс Исходящий интерфейс IP адрес следующего маршрутизатора
10.20.20.0/24 Fa0/0 N/A
1.20.20.44/30 Fa0/1 N/A
130.21.21.24/29 Fa0/1 1.20.20.45
200.20.20.64/27 Fa0/1 1.20.20.45
Номер сети/префикс Исходящий интерфейс IP адрес следующего маршрутизатора
1.20.20.44/30 Fa0/3 N/A
130.21.21.24/29 Fa0/1 N/A
10.20.20.0/24 Fa0/3 1.20.20.46
200.20.20.64/27 Fa0/1 130.21.21.25
Номер сети/префикс Исходящий интерфейс IP адрес следующего маршрутизатора
200.20.20.64/27 Fa0/0 N/A
130.21.21.24/29 Fa0/2 N/A
10.20.20.0/24 Fa0/2 130.21.21.28
1.20.20.44/30 Fa0/2 130.21.21.28

.

Добавить комментарий

Закрыть меню